Automatischer Gruppenbeitritt funktioniert nicht richtig

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Automatischer Gruppenbeitritt funktioniert nicht richtig

    Hallo ich habe heute mal dein Plugin (Automatischer Gruppenbeitritt) installiert. Ich habe bei reg. nichts eingetragen weil neu reg. User nur das Vorstellungseck zu sehen bekommen.
    Dort müssen sie ein Thema (Vorstellen) eröffenen damit die 10 Aktivitätspunkte erreicht werden.

    Die nächste Benutzergruppe ist die "New User", dort habe ich die 10 eingetragen damit der neue Benutzer in diese Gruppe kommt.

    Ich habe mal eine Testregistrierung und eine Vorstellung gemacht um die Funktion zu testen. Ich habe die 10 Aktivitätspunkte werde aber trotzdem nicht in die vorgesehene Gruppe "New User" verschoben. Das manuele abfeuern vom Cronjob ändert auch nichts. Der neue User verbleibt in der Gruppe reg. und wird nicht der New User hinzugefügt so das er nun das ganze Forum sehen kann.
    Einzige änderung der Cronjob wurde auf 2 Minuten eingestellt.

    Installierte Forensoftware:
    WBB 4.0.2 pl 1
    WCF 2.0.2 pl 1

    :EDIT:
    Im ACP unter Benutzer bearbeiten wird zwar vom Cronjob ein Haken zu der richtigen Gruppe gesetzt aber für den User selbst ändert sich nichts, ausser ich klicke im ACP unter Benutzer bearbeiten auf absenden.
    Oder der Benutzer lädt nach seinem ersten Beitrag ein Avatar hoch dann wird er für die zugewiesene Gruppe Aktiviert. Ist auch nicht schlecht, Avatarzwang :D

    Logge ich mich jetzt als neuer User mit oder ohne einen Beitrag erstellt zu haben aus erhalte ich eine einmalige leider zu kurz angezeigte Fehlermeldung mit "Ihre Sitzung ist abgelaufen" und darunter der Inhalt was den Fehler auslöst.

    Im Fehlerlog ist nichts entahlten.
    bx19 ;)

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von bx19 ()

  • Ich habe das gleiche Problem. Mit dem Cronjob habe ich allerdings nichts gemacht. Soll ja auch so funktionieren. Ich habe aber bemerkt, wenn man lange genug wartet dann landet der neue User schon in der entsprechenden Gruppe. Dazwischen liegen dann aber Stunden. Ich benutze es genau so wie bx19 um eine Vorstellung zu erzwingen. Nur kann es nicht Sinn und Zweck der Übung sein, dass der Neue dann wieder Stunden warten muss um dann endlich das ganze Forum sehen zu können.
    Das Plugin ansich ist genau das was ich gesucht habe. :thumbsup:
  • Und ich dachte das ich mit meinen Problem alleine da stehen werde.

    Wie schon erwähnt, ladet der neue User ein Avatar hoch ist das Forum sofort freigeschalten. In der Begrüßungs Nachricht habe ich das mal für die neuen bekannt gegeben das sie ein Avatar nach dem ersten Beitrag hochladen müssen.
    Es funktioniert auch wenn ich als Admin im ACP bin unter Benutzer auflisten bin, den betreffenden User anklicke und auf Absenden ohne was zu ändern klicke.
    bx19 ;)
  • Ich habe es auf einen eingestellt weil ich glaube das da auch was nicht stimmt.

    Ich hatte als Testuser mich vorgestellt und somit die 10 Punkte für die andere Gruppe ereicht aber nix ist passiert.
    Nach einer weile habe ich ein 2. Thema in das Vorstellungsforum geschrieben, macht 20 Punkte und kurz darauf war das Forum frei.

    Deswegen habe ich es mal auf einen Punkt eingestellt.
    bx19 ;)
  • Wie du siehst bist du nicht der Einzige mit dem Problem. :)

    Aber bei dir schein doch etwas anders zu laufen als bei mir. Auch nach dem 2. Thema (20 Punkte) hat sich nichts geändert. Noch immer wartet der Neue ind der Gruppe Registrierter Benutzer auf seine Freischaltung. Registrierung war Heute um 20:11 Uhr. Wenn ich mir vorstelle das ich mich in einem Forum anmelde und dann so lange warten muss bist ich endlich am Forenleben teil haben darf.... Ich glaube ich hätte mir ein anderes gesucht.
  • Du hattest aber doch auch irgend etwas mit den Cronjob gemacht. Vielleicht ist es deshalb anders als bei mir.

    Ja, da müssen wir wohl warten. Bisher läuft mein Forum noch mit einer anderen Forensoftware und ich habe es nicht wirklich eilig. Bin noch am Testen. Aber man ist ja doch neugierig was die anderen denn zum neuen Forum sagen werden :D
  • Der Cronjob sollte alle 3 Stunden laufen, aber das kann man natürlich ändern. Daher dauert es auch ein wenig bis da was passiert.
    Ansonsten muss ich schauen was da los ist, kann ich aktuell nicht sagen ob es da einen Fehler gibt.
    "I do so enjoy my vork..." --- Heinrich Boerner
    "Everything's okay here folks. Nothing to see..." --- Roy Merritt - The Burning Man
  • Ich habe mir das Plugin jetzt auch installiert, damit Benutzer nach einer gewissen Anzahl von Beiträgen in unseren Marktplatz kommen. Nach der Installation habe ich in den Einstellungen der Benutzergruppe eingetragen, dass 30 Punkte erreicht werden müssen, um in diese Benutzergruppe zu kommen. Im Anschluss habe ich direkt den Cronjob manuell ausgeführt.

    Vor der Ausführung des Cronjobs waren 165 Benutzer in der Gruppe und danach sind es nun 168 Benutzer. Bei mir scheint das Plugin also genau seinen Sinn zu erfüllen. Ich werde wohl nur den Cronjob etwas kürzer einstellen. :)
  • Toby schrieb:

    Kannst du mir mal deine exakten Einstellungen nennen? Oder hast du ein Testforum wo ich mir das ansehen kann? Also inkl. Datenbankzugriff?

    Falls du mich meinst.
    Ich habe zur Zeit kein Testforum am laufen. Meine Einstellungen und rechte sind so aufgebaut.

    Es gibt folgende Benutzergruppen.

    1. Registrierte
    2. New User (10 Punkte) derzeit 1 Punkt
    3. Power User (200 Punkte)
    4. Top User (3000 Punkte)
    Registriert sich jemand und aktiviert seinen Account sieht er nach dem ersten Login nur das Vorstellungs-Forum. Neuregistrierte haben im Prinzip so gut wie keine Rechte.
    Stellt sich der neue vor so bekommt er 10 Punkte für den erstelten Thread und wird laut Cronjob (derzeit 1 min.) in die New User Gruppe verschoben.
    Nach dieser Minute sollte er den großteil vom Forum einsehen können.
    Ab Power-User bekommt man noch mehr rechte und als Top User steht alles zu Verfügung.
    Wie schon weiter zuvor beschrieben habe ich mich mit einen Testaccount neu registriert und Aktiviert. Ich sehe nur das Vorstellungs-Forum. Ich eröffne ein neues Thema, stelle mich vor und habe 10 Punkte. Nach mehreren Minuten aktualisiere ich meinen Browser und es hat sich nichts geändert.
    Im ACP bin ich jedoch in der Gruppe New User.
    Nach dem Hochladen von einem Avatar aus den Frontend sehe ich dann tatsächlich das ganze Forum.
    Oder ich gehe im ACP zu Benutzer klicke meinen Usernamen an ändere aber dort nichts und klicke auf absenden. Dann sehe ich ebenfalls das ganze Forum als New User.
    Ich denke das es nur dann Funktioniert wenn unter dem Benutzeraccount was angestoßen wird bzw. eine änderung erfolgt.

    Ich hoffe du verstehst was ich meine.
    bx19 ;)
  • Ja, genau du warst gemeint, bx19. ;)
    Ich hab das jetzt mal nachgebaut, neuer Benutzer, neue Gruppe in die man ab 1 Punkt aufgenommen wird, einen Post gemacht und dafür 10 Punkte bekommen, Cronjob manuell ausgeführt, Testbenutzer war in der Gruppe drin.
    Was allerdings stimmt, ist, das man erst aufgenommen wird, wenn man mehr als die eingestellten Punkte hat. Wenn deine "New User" also 10 als notwendige Punktezahl haben, dann wird man erst mit 11 Punkten aufgenommen.
    Wenn man dann aber 9 einstellt, gehts. Ich ändere das aber, das man auch aufgenommen wird wenn man exakt die notwendige Punktezahl hat.
    "I do so enjoy my vork..." --- Heinrich Boerner
    "Everything's okay here folks. Nothing to see..." --- Roy Merritt - The Burning Man
  • bisher funktioniert es ja wunderbar und es erleichtert einem die Arbeit als Admin ungemein.

    da ich bei den Cronjobs eine absolute niete bin würde ich gerne Wissen was ich eintragen muss damit der cronjob nach 1 oder 2 Minuten ausgeführt wird und die User schnell in die neuen Bereiche kommen .

    Wäre echt super wenn mir da jemand auf die Sprünge helfen könnte